Application doesn't work for new installations

Incident Report for Elements Apps

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 12:05 UTC

Update

A fix has been implemented and is currently undergoing testing before release.
Posted Sep 29, 2025 - 08:44 UTC

Identified

Starting from Tuesday the 16th, new installations of Elements Copy & Sync are experiencing issues. After installation, some functionalities, including issue creation, are not working correctly.

The problem has been identified and the Dev team is actively working on a fix.
Posted Sep 23, 2025 - 11:42 UTC
This incident affected: Elements Copy & Sync.